From Fab Lab Bcn WIKI
Jump to: navigation, search

Digital Fabrication

3D Printing

How to prepare files for 3D print. Option A

  • Rhinoceros 4.0

Since most people will be generating their models from within Rhino, this guide will show instructions specifically tailored to it. These steps are analogous in any other modeling application, though the specific commands may differ.

  • Analyze your model

Analyzing your model is the most important step to making sure that your print comes out successfully. There are 4 basic things that you need to check to make sure that the object is ready for meshing, and instructions below will show you how to do this:

1. object is valid AND closed (i.e. airtight) ***NO NAKED EDGES*** 2. object contains no BAD surfaces and/or objects 3. object DOES NOT intersect itself 4. object surface normals are consistent.

    • 1. valid & closed

to check that the intended object is valid and closed, in Rhino select the object

Edit menu: Object Properties

Or on the standard toolbar, click Object Properties

select ‘Details…’

Make sure the dialog says “Valid polysurface” AND “Closed solid polysurface…” in the text if your object is NOT a ‘closed solid polysurface’, you need to close it. The first thing you need to do is find where there is an opening. If it is not obvious, you can try using the ‘show naked edges tool’

Analyze menu: Edge Tools > Show edges

Select the Naked Edges box

This now highlights the free edges in your model. These need to be sealed up using any number of normal modeling methods before you can continue

    • 2. bad objects

Rhino is a NURBS modeler, and sometimes geometry is created that does not obey NURBS rules, and causes errors. There is an off chance that your model has a bad object in it.

Analyze: Diagnostics > Select bad objects

if a bad object is selected, then simply delete it. Otherwise continue on.

    • 3. self-intersecting solid

Make sure your object does not have geometry that intersects itself. This will jeopardize a successful print. You will need to rebuild your model such that it does not do so.

    • 4. Surface Normals

Select your object. Select Analyze > Direction from the menu and confirm that all surface normals are oriented in the same direction.

  • Create a mesh of your model – and check it

Rhino generates a mesh in order to export the file to the .STL format. There are factors that you will want to specify based on the geometry of your part in order to ensure that your 3D print comes out looking acceptable.

Tools menu: Polygon Mesh > From NURBS Object

  • Select the objects

Go to ‘Detailed controls…’

make sure your dialog box resembles the one shown here.

n. b. these values are for millimeter-based models, the ‘maximum edge to surface box’ should reflect the units and scale of your object. It defines the accuracy of the mesh. A value of zero in any box disables the function.

This procedure is automatically invoked when you go to export your model, but if you are unfamiliar with this process or wish to exercise greater control over the mesh generation, you will want to do this as a separate step.

  • check it

right-click on the viewport name and make sure you are in shaded view

right-click the viewport name again and select flat shade. This will visualize what the mesh looks like, and it will be a good indicator to what your final printed part will look like. If the mesh is too jagged, simple delete the mesh and re-mesh the original model with a higher tolerance.

  • export your model

select the mesh you have just created (not the original polysurface!)

File menu: Save as > Save as type:

Select ‘Stereolithography (*.stl)’ format

Make sure to specify a Binary file format in the STL Export Options dialog box. To confirm a good model: import the .stl file back into rhino, and analyze it in a similar fashion as outlined above. The CheckMesh help file in Rhino is extremely useful in troubleshooting bad meshes.

How to prepare files for 3D print. Option B

(from Syracuse University School of Architecture)

  1. Models are created in 3D programs such as Rhino and must be saved in STL format. Use the following steps to prepare your model in Rhino 4.0.
  2. When working with surfaces, use BooleanUnion to combine the objects into one polysurface. Click Solid > Union.
  3. After the Union command has been applied, create a Polygon Mesh. Highlight the object, select Mesh > From NURBS Object. With highly curved surfaces, increase the number of triangles in the mesh. Straight surfaces need less.
  4. Next, click the object to select the Polygon Mesh.
  5. Issue the command CheckMesh to see if you have a good mesh. If you have a bad mesh, search the Rhino help for 'check/repair meshes' . This will give you many fix-it commands. A common problem is naked or unjoined edges, which can be revealed with the command ShowEdges, and usually fixed with the MatchMeshEdge command. FillMeshHoles will repair holes, but is more likely to change the shape of the model. ExtractDuplicateMeshFaces will separate identical faces for easier removal, but be aware it could generate naked edges. It may be helpful to make a copy of the mesh before using these tools in order to check the results. Visit this page for more tips on creating a good stl file from Rhino.
  6. When done fixing the model, export the Polygon Mesh as an STL file. Select the mesh, then click File > Export Selected. Change the Save As Type to STL. When the File Type Options appears, choose BINARY.

DigiFab Assignment Template

Laser Cutting

MAA 2010-11 Digital Fabrication Class

Ribbing process



  • Material: 3mm plywood
  • Laser cutter machines: 75w Epilog Laser, 100w Spirit GE
  • Rhinoceros modeling
  • Postcript machine interface


The objective of ASSIGNMENT 1 is to introduce students to the SUBTRACTIVE 2D numeric fabrication processes, focusing on the technique of cutting through the use of a Laser Cut machine. Each student will be given the chance to work directly with the machine (supervised by a Fab-Lab instructor).

In terms of design, the intention of the class is to produce a large scale installation, where each student will contribute by fabricating one of its parts. The challenge of the assignment is to produce a portion of a three-dimensional piece of scaled furniture, constructed with planar sections and assembled in a way like a cage with planar ribs. Students will be given geometric constraints for the end sections of their individual part (such to standardize the ends of all segments) and thus facilitate the overall assembly and allow for possibilities of variation in the final arrangement. The final sections of the piece parts will be the same as the given model (instead of 50mm, we will be using 20mm, by scale reasons).


Students will be using a Rhinoceros template file, in order to facilitate the resolution of the assignment

STEP 1: CREATE THE SURFACE Open the template. Go to Menu Transform>Cage Editting>Cage Edit to alter your surface to the desired state. You may choose more or less number of control points for editing.

IMPORTANT NOTE: In order to keep surface normals for continuity at the ends, you may not pull on the final 2 rows of control points.

STEP 2: OFFSET THE SURFACE Create an interior copy of the surface, with an offset distance at the ends from 20mm to 50mm (again: different from the 50mm section given)

STEP 3: CREATE THE CROSS RIBS Create cross section contours of your pipe, at from 20mm to 50mm (subjected to desired results) on center. Menu Curves / Curves from Objects / Contour Use each pair of curves and loft them or use the command “planar surface” to generate each cross section rib. Copy the end cross ribs in order to reloft your surface and maintain surface normals. Now, select all of your ribs, and reloft the inner and outer surfaces.

STEP 4: CREATE THE LONGITUDINAL CONTOURS Now use the contour command to produce sections in the longitudinal direction. You are open to place these as you wish, but they must be at a perpendicular angle to the cross ribs in order for joints to work properly.

STEP 5: INTERSECTING THE RIBS Find the intersection lines between all ribs. Use one of the intersection lines to create a pipe, and move it from the end to the mid point of that same intersection line. Menu Solid / Pipe Mirror the pipe from the midpoint of the line, and pace it in a separate layer Menu Transform / Mirror Extrude the corresponding longitudinal rib, to thicken it to 0.1 cms Menu Solid / Extrude Surface / Straight Remove the cylinders from the solid rib, to get the proper egg-crate intersection Menu Solid / Difference Do the same process for all ribs, using: The cylinders pointing inwards to cut the longitudinal ribs The cylinders pointing outwards to cur the cross ribs

STEP 6: UNFOLDING THE RIBS Unfold each one of the solid ribs, keeping only one f the surfaces to extract the edge contour. Menu Surface / Unroll Developable Surf.

STEP 8: DUPLICATE EDGE + LABELS Duplicate the edge of the unrolled surface, before deleting it. Join all curves of the contour and insert a text block to label it. Place the contour on layer CUT and the label on the layer ENGRAVE, before grouping together contour + label. Menu Curves / Curves from objects / Duplicate Edge Menu Edit / Group Menu Dimension / Text block Repeat the process for all ribs, and finish the assignment by placing all the groups of rib+label inside the material limits (by given measures of machines). Select both material limits and all contours inside, and export them into a new file, named as follows:

DIGIFAB_Assign2_LASER_Your name.3dm

Menu File / Export Selected IMPORTANT: Please make sure that in the LASER file you only have 3 active layers: 1) Layer 1: MATERIAL (Blue) 2) Layer 2: CUT (Black) 3) Layer 3: ENGRAVE (Red)

_ MATERIAL AND SUPPLY The assignment will be cut out of 3mm thick plywood, in sheets of 450mm x 960mm (DHUB LASER) or 900mm x 600mm (IaaC Laser) The material may be acquired from a company near by IAAC:

Assignment2 CNC Cutting.jpg BRICOLAJE XILOS C/ Pere IV, 121 08018 Barcelona Tel: +34 933009118

_DEADLINE The assignment is due on THURSDAY, NOV 04 at 4PM

_REQUIREMENTS Please have the following documents ready to hand in:

1_ A DXF of your 2D cutting file 2_ A complete post at your site in IaaC blog documenting the whole process including: 3D model 3D model (sections) Cutting file Exploded axonometric views with instructions for assembly Photographs of the cutting process Photographs of the assembly process

This document is an adaptation from the Digital Fabrication class taught by Marta Male-Alemany, with Francisca Aroso and Shane Salisbury as assistants.

DigiFab Assignment Template


  • Large Scale Laser Cutter, by Astrid Lubsen
  • Precix Milling Machine setup, By Cesar Cruz
  • Rhino CAM quick guide, By Live Architecture Network (LaN)


  • CNC Milling estimator

Note: it calculates in inches, but it also has an unit converter

  • Fab Lab Barcelona Machine Reservation: Machine reservation page]

Note: Please create a new user, and reserve with two days in advance


Grasshopper tools

This category currently contains no pages or media.